glitch filter

This is a pack of GIF overlay files, filters and Photoshop Droplets. You can use all of some of them to achieve the look that you want. 

Compatibility

  • Breeze DSLR Remote Pro 3.5 and above
  • Photoshop CC*
  • Any photo booth software that supports droplets**

* likely will work on older versions of Photoshop, but has not been tested. Photoshop is only required for the Filter effects, and not the overlays.

** currently has only been tested on Breeze. We will update the compatibility information as we test further.

Join our User Group | Back to The Lab →